I arrived 9-15-2026 from Amazon. If was a "like new" used item. Full price would have been $293. I paid $181. I now see the "like new" offered for $270. I would never have bought a "refurb" at that price and would have gladly paid the extra $20 for an actual new drive. What are they thinking?
I dug up a USB-A to C cable and plugged it into my linux machine:
Sep 15 17:38:56 trona kernel: usb 1-1.3: new high-speed USB device number 82 using ehci-pci Sep 15 17:38:56 trona kernel: usb 1-1.3: New USB device found, idVendor=1058, idProduct=260d, bcdDevice=20.07 Sep 15 17:38:56 trona kernel: usb 1-1.3: New USB device strings: Mfr=2, Product=3, SerialNumber=1 Sep 15 17:38:56 trona kernel: usb 1-1.3: Product: My Passport 260D Sep 15 17:38:56 trona kernel: usb 1-1.3: Manufacturer: Western Digital Sep 15 17:38:56 trona kernel: usb 1-1.3: SerialNumber: xxx Sep 15 17:38:56 trona kernel: usb-storage 1-1.3:1.0: USB Mass Storage device detected Sep 15 17:38:56 trona kernel: scsi host10: usb-storage 1-1.3:1.0 Sep 15 17:38:57 trona kernel: sd 10:0:0:0: Attached scsi generic sg2 type 0 Sep 15 17:38:57 trona kernel: ses 10:0:0:1: Attached Enclosure device Sep 15 17:38:57 trona kernel: ses 10:0:0:1: Attached scsi generic sg3 type 13 Sep 15 17:38:57 trona kernel: sd 10:0:0:0: [sdc] Spinning up disk... Sep 15 17:38:57 trona kernel: ses 10:0:0:1: Wrong diagnostic page; asked for 1 got 8 Sep 15 17:38:57 trona kernel: ses 10:0:0:1: Failed to get diagnostic page 0x1 Sep 15 17:38:57 trona kernel: ses 10:0:0:1: Failed to bind enclosure -19 Sep 15 17:39:02 trona kernel: .....ready Sep 15 17:39:02 trona kernel: sd 10:0:0:0: [sdc] Very big device. Trying to use READ CAPACITY(16). Sep 15 17:39:02 trona kernel: sd 10:0:0:0: [sdc] 9767475200 512-byte logical blocks: (5.00 TB/4.55 TiB) Sep 15 17:39:02 trona kernel: sd 10:0:0:0: [sdc] 4096-byte physical blocks Sep 15 17:39:02 trona kernel: sd 10:0:0:0: [sdc] Write Protect is off Sep 15 17:39:02 trona kernel: sd 10:0:0:0: [sdc] No Caching mode page found Sep 15 17:39:02 trona kernel: sd 10:0:0:0: [sdc] Assuming drive cache: write through Sep 15 17:39:02 trona kernel: sdc: sdc1Linux automounts it and I see a desktop icon "5.0 TB Volume".
mount | grep sdc /dev/sdc1 on /run/media/tom/43C3-E6DE type exfat (rw,nosuid ....Nothing on the drive. I copy a file to it, and it seems to work fine. The linux logs show no errors during the copy.